解决oneinstack环境下wordpress安装或升级插件需要输入FTP账户密码

  • 解决oneinstack环境下wordpress安装或升级插件需要输入FTP账户密码已关闭评论
  • 22 views
  • A+
所属分类:VPS新手教程

安装了wordpress之后或多或少的都要安装几个插件,大部分人并不会下载插件上传到网站相应的目录里安装,而是直接在线安装,于是乎有些新手朋友就会遇到一个问题,在安装或者升级的时候,会要求你提供FTP密码。这里就讲一下如何解决这个问题。

之所以会出现要求你输入FTP密码的情况,是因为你网站根目录的文件权限不够。这里解决方法也比较简单,直接通过ssh登录你的VPS,然后执行以下三条命令。

chown -R www.www /data/wwwroot/
find /data/wwwroot/ -type d -exec chmod 755 {} \;
find /data/wwwroot/ -type f -exec chmod 644 {} \;

执行完以上命令之后,刷新一下你的wordpress的后台,就可以正常的安装或者升级了。不会再要求你输入FTP密码了。以上命令来自oneinstack官方问答社区。

PS:如果你wwwroot目录下有多个网站,每新增一个网站之后,就再执行一下以上的命令。